User invitation issues
Incident Report for Threat Stack
Resolved
User invitations should be operating normally.
Posted Feb 09, 2021 - 13:48 EST
Investigating
We're investigating an issue related to inviting users to organizations.
Posted Feb 09, 2021 - 13:15 EST